Back to overview
Resolved

We are investigating reports of slowness in the AWS US region

Aug 19, 2026 at 6:34am UTC
Affected services
Blink Application Frontend
Blink Application Backend
Interactive bots
Authentication

Resolved
Aug 19, 2026 at 7:38am UTC

We’ve implemented a fix and are actively monitoring the recovery. We are also resuming the execution queue and closely monitoring its progress. We’ll continue to provide updates as the system stabilizes.

Updated
Aug 19, 2026 at 7:04am UTC

We’ve resumed database operations and are actively working to mitigate the remaining impact. We’ll continue to monitor the situation closely and share further updates as more information becomes available.

Updated
Aug 19, 2026 at 6:45am UTC

We’ve identified a database availability issue contributing to the ongoing impact. Our team is actively working to restore database availability and mitigate further disruption. We’ll share another update as more information becomes available.

Created
Aug 19, 2026 at 6:34am UTC

We've identified elevated load in the affected region and are actively working to mitigate impact. We'll share updates as more information becomes available.