Back to overview
Resolved

Blink Tables Degraded in AWS US Region

Aug 13, 2026 at 7:10am UTC
Affected services
Blink Application Backend

Resolved
Aug 13, 2026 at 7:57am UTC

We identified the root cause and have resolved the issue. Thank you for your patience!

Created
Aug 13, 2026 at 7:10am UTC

Blink Tables in the AWS US region is experiencing degraded performance and availability, impacting Case Management and workflows using Tables. Our team is actively investigating.